Skocz do zawartości


Zdjęcie

Jak zabezpieczyć AuthMe Reloaded przed pewną luką


  • Zaloguj się, aby dodać odpowiedź
6 odpowiedzi w tym temacie

#1 supermichalpol

supermichalpol

    Dużo pisze

  • Klient
  • 590 postów
  • Typ konta:Premium
  • Minecraft:supermichalpol

Napisano 24 February 2014 - 16:27

Witam, gdyż od dawna AuthMe Reloaded jest pewien bug np. Ja jestem administratorem serwera i mam nick supermichalpol, jeśli ktoś wejdzie z moim nickiemale na początku dopisze "?" (czyli na moim nickuby wyglądało: ?supermichalpol) i się zarejestruje to będzie miała taka osoba dostęp do komend takich jak np. /gm 1 itp. Jak się zabezpieczyć? Wchodzimy w config.yml w folderze AuthMe i szukamy linijki 54 (przynajmniej tak jest w wersji AuthMe - 3.3.3) i zmieniamy:

    allowedNicknameCharacters: '[a-zA-Z0-9_?]*'

na

    allowedNicknameCharacters: '[a-zA-Z0-9_]*'

ZAKAZ KOPIOWANIA PORADNIKA I PRZYWŁASZCZANIA GO SOBIE

Poradnik Napisany przez supermichalpol


Pomogłem ci lub spodobał ci się mój artykuł? Kliknij "Lubię to", i kliknij na mój obrazek:

|

|

V

Dołączona grafika


Dzięki :D


#2 Wazukup

Wazukup

    Stały bywalec

  • Stały Klient
  • 1963 postów
  • Typ konta:Non Premium

Napisano 24 February 2014 - 18:28

Podejrzewam że większość serwerów "OGARNIĘTYCH" tej luki nie zabiezpieczyła dla tego można się łatwo włamać ^^ / za poradnik byłby oczywiście plus, niestety reputacji nie ma.

13.10.2012 - 6.03.2015
Dziękuje za współpracę!
Moje GG: 42841968.


 


#3 TheRodzioPL

TheRodzioPL

    Admin hostingu MineServ

  • Administrator Mineserv.eu
  • 757 postów
  • GG:49491877
  • Typ konta:Premium
  • Minecraft:TheRodzioPL

Napisano 24 February 2014 - 18:51

wiem o tym, ale poradnik dobry przyda się tym co niewiedza

therodziopl.png
reklama.png

 

 


#4 NorthPL

NorthPL

    Stały bywalec

  • Stały Klient
  • 1174 postów
  • Typ konta:Non Premium
  • Minecraft:NorthPL

Napisano 25 February 2014 - 10:23

Ja to zabezpieczyłem od razu kiedy się o tym dowiedziałem, pisałem nawet tu na shoutboxie.

 

PS. To działa tylko na komendy Essentials...



#5 majker2000

majker2000

    Użytkownik

  • Stały Klient
  • 169 postów
  • Typ konta:Premium

Napisano 16 May 2014 - 18:48

DZIĘKI! jesteś Bogiem! dziś miałem taką sytuację!


majker2000.png


#6 radzik321

radzik321

    Użytkownik

  • Klient
  • 61 postów
  • Typ konta:Non Premium

Napisano 27 May 2014 - 10:23

Ja na szczęście nie musiałem nic zmieniać bo już tak miałem  :P ale poradnik przydatny  :)



#7 krzukosz

krzukosz

    Świeżo zarejestrowany

  • Klient
  • 7 postów

Napisano 11 November 2014 - 14:29

W nowszych wersjach już tego nie ma. Ale jeśli ktoś np korzysta z automatycznego instalatora z panelu to wersja nie musi być najnowsza i luka nadal może występować.






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych